Flash Builder 4.7 AIR SDK Troubles

Just a quick note to self, eventually for those who are facing the same troubles. When you switch workspace to ones created by Flash Builder 4.5 or lower, Flash Builder 4.7 WARNS YOU that you might experience unexpected results.

Therefor, when you are selecting “New” > “ActionScript Mobile AIR Project”, immediately after typing the project name, you will get an error like “The selected Flex SDK does not support building mobile projects”. If you go to “preferences” > “Flash Builder” > “Installed AIR SDK” you will notice that there is no AIR SDK known to Flash Builder.

Also, I’ve noticed that the compiler gets really confused in the case of libraries that are monkey patching SDK classes.

Be careful what you expect when working with old workspaces : it’s best to create a new workspace and import a copy of all projects for getting good results. But hey, maybe someone at Adobe will have the time to make an workspace importer tool… or not.